Impact to Shoplazza Reports And Dashboards services

Incident Report for Shoplazza

Resolved

This incident has been resolved.
Posted Jul 24, 2022 - 21:21 CST

Investigating

We are investigating cases of degraded performance for reports and dashboards customers. We will provide more details within the next hour.
Posted Jul 24, 2022 - 21:10 CST
This incident affected: Reports And Dashboards.